Problems with managed samples

May 23, 2009 at 11:44 AM

I am on Windows Vista (+SP1) 32 Bit and logged in as administrator.

UAC is also turned off.

When i run the samples (FileMon or ProcessMon) i always get

"This is an administrative task!"  ... "Permission denied..."

So what am i doing wrong ?

Any help welcome,

thx in advance!



May 23, 2009 at 7:47 PM

Try press right mouse btn menu, choose "Run as administrator" for the program.

If I am not mistaken, Vista doesn't run the apps under admin even for admin accounts by default.

Regards, Igor.

May 23, 2009 at 7:54 PM

I tried to run it with right mouse-button as administrator, same result.

I am even getting this error under xp (also admin account).

May 23, 2009 at 8:19 PM
> "This is an administrative task!" ... "Permission denied..."
> So what am i doing wrong ?

Given that the error message is generated inside the
Filemon/ProcessMonitor source code in response to an exception probably
happening inside config.cs, I'd suggest first checking what exactly goes
wrong where.

May 23, 2009 at 10:19 PM

imho it might happens if doesn't found the binaries ( filemon.exe, filemoninject.dll etc ) for registration in GAC. Try to debug.


May 23, 2009 at 10:24 PM

Thx folks.

It was indeed some missing DLL's. Running the sample out of the box inside visual studio wasn't a good idea.

Now, do you guys think i could use the .net version in my MFC/app somehow ?

I couldn't get the injection dll running with the unmanaged version. So i am thinking about to encapsulate everything inside a managed version and call it from my mfc app if needed. This approach requires somewho a communication betweeb my mfc app and the managed part. Do you guys have any ideas or suggestions ?

Any of you has working unmanaged dll injection samples ?

once again,

many thx in advance



May 31, 2009 at 10:49 AM

I used the managed version in my app.

As for communication between mfc and .net console i used named pipes and until now its working fine.