STATUS_INTERNAL_ERROR: Unknown error in injected assembler code (Code 5 )

Sep 12, 2013 at 8:52 AM
I'm getting this a lot :( Has anyone else ? It happens even if I make my injection dll ( which is managed code ) have a run method with only a return in it.

I don't think it's a x86/x64 conflict, as that usualy brings up the 'bad format' exception instead. Likewise, I don't think it's a filepath prblem, as that brings up either a file not found or a 'method rtl*** was not found in module' kind of error.

If anyone has experienced this error and can give me a heads up on it, I'd be grateful !
Sep 16, 2013 at 10:16 AM
For anyone who got here by google, it eventually turned out that this only occurs when I run from Visual Studio. I get around it by running the process from the command line and connecting the debugger to it after the hooking has taken place.

I tried turning off the 'enable visual studio hosting process' for various components, but this had no effect :(
Marked as answer by spazzarama on 2/14/2014 at 11:10 PM
Nov 18, 2014 at 10:50 AM
Unfortunately, in my case it crashes still.

I tried to let the code go on without connecting with the debugger and the target exe crashed.